import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:Saldo|Total)\\s(?!0[.,]00\\b)\\d{1,3}(?:,\\d{3})*\\.\\d\\d\\b";
final String string = "1.214,41\n"
+ "4,431.43\n"
+ "143,134.43\n"
+ "355.352,41\n"
+ "443,113,134.43\n"
+ "365.115.352,41\n\n\n"
+ "Total 341,431.43\n"
+ "Saldo 0.00\n"
+ "Saldo 0,00\n"
+ "Total 1,431.43\n"
+ "Total 0,00\n"
+ "Saldo 0.60";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}