import re
regex = re.compile(r"\b(?:Saldo|Total)\s(?!0[.,]00\b)\d{1,3}(?:,\d{3})*\.\d\d\b", flags=re.MULTILINE)
test_str = ("1.214,41\n"
"4,431.43\n"
"143,134.43\n"
"355.352,41\n"
"443,113,134.43\n"
"365.115.352,41\n\n\n"
"Total 341,431.43\n"
"Saldo 0.00\n"
"Saldo 0,00\n"
"Total 1,431.43\n"
"Total 0,00\n"
"Saldo 0.60")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")