package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|(!\[[^][]+]\([^()]+\))(\[[^][]+]\([^()]+\))|(!\[[^][]+]\[[^][]+])(\[[^][]+]\([^()]+\)))`)
var str = `[text](link) ![image][link][text](link)
 [text](link)`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}