re = /(?|(!\[[^][]+]\([^()]+\))(\[[^][]+]\([^()]+\))|(!\[[^][]+]\[[^][]+])(\[[^][]+]\([^()]+\)))/m
str = '[text](link) ![image][link][text](link)
 [text](link)'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result