$re = '/(?|(!\[[^][]+]\([^()]+\))(\[[^][]+]\([^()]+\))|(!\[[^][]+]\[[^][]+])(\[[^][]+]\([^()]+\)))/m';
$str = '[text](link) ![image][link][text](link)
 [text](link)';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;