import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\])\"(?!.*?>|\\[)";
final String string = "data-placeholder=\"\"[Refer\" to \"Conditions To Entry Of The Confirmation Order\" and \"Conditions To Effective Date\" sections]\"\n"
+ "<img src=\"logo.jpg\" alt =\"\">";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}