$re = '/(?<!\])"(?!.*?>|\[)/m';
$str = 'data-placeholder=""[Refer" to "Conditions To Entry Of The Confirmation Order" and "Conditions To Effective Date" sections]"
<img src="logo.jpg" alt ="">';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;