re = /(?<!\])"(?!.*?>|\[)/m
str = 'data-placeholder=""[Refer" to "Conditions To Entry Of The Confirmation Order" and "Conditions To Effective Date" sections]"
<img src="logo.jpg" alt ="">'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result