const regex = /(?<!\])"(?!.*?>|\[)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\])"(?!.*?>|\\[)', 'gm')
const str = `data-placeholder=""[Refer" to "Conditions To Entry Of The Confirmation Order" and "Conditions To Effective Date" sections]"
<img src="logo.jpg" alt ="">`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);