using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*""(?:IpAddress"":""\K[0-9]{1,3}(?:\.[0-9]{1,3}){3}|WorkstationName"":""\K[^""]*)(?="")";
string input = @"# IPADDR = 192.10.10.10
... ""WorkstationName"":""WS-8300E-007"",""IpAddress"":""192.10.10.10"" ...
# IPADDR = WS-8300E-007
... ""WorkstationName"":""WS-8300E-007"",""IpAddress"":""-"" ...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}