import re
regex = re.compile(r"^.*\"(?:IpAddress\":\"\K[0-9]{1,3}(?:\.[0-9]{1,3}){3}|WorkstationName\":\"\K[^\"]*)(?=\")", flags=re.MULTILINE)
test_str = ("# IPADDR = 192.10.10.10\n"
"... \"WorkstationName\":\"WS-8300E-007\",\"IpAddress\":\"192.10.10.10\" ...\n\n"
"# IPADDR = WS-8300E-007\n"
"... \"WorkstationName\":\"WS-8300E-007\",\"IpAddress\":\"-\" ...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")