#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)https?\:\/\/(.*?(?<!cgi\.)ebay)"
Local $sString = "http://www.ebay" & @CRLF & _
"http://ebay.com" & @CRLF & _
"https://ebay.com" & @CRLF & _
"http://cgi.ebay" & @CRLF & _
"https://precgi.ebay" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")