$re = '/https?\:\/\/(.*?(?<!cgi\.)ebay)/i';
$str = 'http://www.ebay
http://ebay.com
https://ebay.com
http://cgi.ebay
https://precgi.ebay
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);