import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?\\:\\/\\/(.*?(?<!cgi\\.)ebay)";
final String string = "http://www.ebay\n"
+ "http://ebay.com\n"
+ "https://ebay.com\n"
+ "http://cgi.ebay\n"
+ "https://precgi.ebay\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}