re = /https?\:\/\/(.*?(?<!cgi\.)ebay)/i
str = 'http://www.ebay
http://ebay.com
https://ebay.com
http://cgi.ebay
https://precgi.ebay
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end