#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(https?:\/\/[\w]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>"
Local $sString = "<https://sky.slack.com/messages/2233/3333/33>" & @CRLF & _
"" & @CRLF & _
"<https://sky.slack.com/>" & @CRLF & _
"" & @CRLF & _
"<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")