import re
regex = re.compile(r"<(https?:\/\/[\w]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>")
test_str = ("<https://sky.slack.com/messages/2233/3333/33>\n\n"
"<https://sky.slack.com/>\n\n"
"<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")