package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(https?:\/\/[\w]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>`)
var str = `<https://sky.slack.com/messages/2233/3333/33>
<https://sky.slack.com/>
<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}