const regex = /<(https?:\/\/[\w]+(?:\.[\w]+)+(?:\/[\w-?=%&@$#_.+]+)*\/?)(?:\|((?:[^>])+))?>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(https?:\\\/\\\/[\\w]+(?:\\.[\\w]+)+(?:\\\/[\\w-?=%&@$#_.+]+)*\\\/?)(?:\\|((?:[^>])+))?>', 'g')
const str = `<https://sky.slack.com/messages/2233/3333/33>
<https://sky.slack.com/>
<https://sky.slack.com/messages/@george.richmond/team/|@george.richmond>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}