using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(assertTrue)(.+?)( ==)";
string input = @" $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == 'edited');
$this->assertTrue($post->type == 'Action Item');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First ""Replace"" string, and the following in the second:
AssertEquals$2,";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}