re = /(assertTrue)(.+?)( ==)/
str = ' $this->assertTrue($post->item_id == $actionItem->id);
$this->assertTrue($post->action == \'edited\');
$this->assertTrue($post->type == \'Action Item\');
$this->assertTrue($post->title == $actionItem->title);
Designed for use in PHPstorm. REGEX in First "Replace" string, and the following in the second:
AssertEquals$2,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end