import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(assertTrue)(.+?)( ==)";
final String string = " $this->assertTrue($post->item_id == $actionItem->id);\n"
+ " $this->assertTrue($post->action == 'edited');\n"
+ " $this->assertTrue($post->type == 'Action Item');\n"
+ " $this->assertTrue($post->title == $actionItem->title);\n\n"
+ "Designed for use in PHPstorm. REGEX in First \"Replace\" string, and the following in the second:\n"
+ "AssertEquals$2,";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}