using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\.).+@";
string substitution = @"";
string input = @"abc.ned@hd.com
asdasd@nd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}