$re = '/(?=\.).+@/';
$str = 'abc.ned@hd.com
asdasd@nd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;