import re
regex = re.compile(r"(?=\.).+@")
test_str = ("abc.ned@hd.com\n"
"asdasd@nd")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)