import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(SHOW:.*?)\\s+\\d{1,2}:\\d{1,2}\\s+[AP]M\\b";
final String string = "SHOW: Game of Thrones 7:00 PM EST\n"
+ "SHOW: The Outsider 3:00 PM EST\n"
+ "SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}