import re
regex = re.compile(r"\b(SHOW:.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b", flags=re.MULTILINE)
test_str = ("SHOW: Game of Thrones 7:00 PM EST\n"
"SHOW: The Outsider 3:00 PM EST\n"
"SHOW: Don't Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")