re = /\b(SHOW:.*?)\s+\d{1,2}:\d{1,2}\s+[AP]M\b/m
str = 'SHOW: Game of Thrones 7:00 PM EST
SHOW: The Outsider 3:00 PM EST
SHOW: Don\'t Be a Menace to South Central While Drinking Your Juice In The Hood 10:00 AM EST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end