#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imx)<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["']?\K([^<>'"\s]+(?:\/(?!>)|\b))(?=[^<>]*>)"
Local $sString = "This should succeed:" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href="http://example.com/tsr-opensearch/" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href="http://www.example.com/search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href="/search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href="search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href="./search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href='http://www.example.com/search.xml' title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml title="" />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/>" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/dsfdsf/search.xml />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://href.example.com/search.xml/ />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" hre href=http://href.example.com/search.xml/ />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" ref="adfsf" href=http://href.example.com/search.xml/ />" & @CRLF & _
"" & @CRLF & _
"Should fail:" & @CRLF & _
"<link rel="stylesheet" type="text/css" href="theme.css">" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml>" & @CRLF & _
"link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>" & @CRLF & _
"link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />" & @CRLF & _
"<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")