$re = '/<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["\']?\K([^<>\'"\s]+(?:\/(?!>)|\b))(?=[^<>]*>)/imx';
$str = 'This should succeed:
<link rel="search" type="application/opensearchdescription+xml" href="http://example.com/tsr-opensearch/" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="http://www.example.com/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="./search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=\'http://www.example.com/search.xml\' title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/dsfdsf/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" hre href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" ref="adfsf" href=http://href.example.com/search.xml/ />
Should fail:
<link rel="stylesheet" type="text/css" href="theme.css">
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);