import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=[\"']?\\K([^<>'\"\\s]+(?:\\/(?!>)|\\b))(?=[^<>]*>)";
final String string = "This should succeed:\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\"http://example.com/tsr-opensearch/\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\"http://www.example.com/search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\"/search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\"search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\".search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\"./search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=\".search.xml\" title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href='http://www.example.com/search.xml' title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml title=\"\" />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml>\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml/>\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/dsfdsf/search.xml />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml/ />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml/ />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://href.example.com/search.xml/ />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" hre href=http://href.example.com/search.xml/ />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" ref=\"adfsf\" href=http://href.example.com/search.xml/ />\n\n"
+ "Should fail:\n"
+ "<link rel=\"stylesheet\" type=\"text/css\" href=\"theme.css\">\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href= http://www.example.com/search.xml />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href= http://www.example.com/search.xml>\n"
+ "link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml>\n"
+ "link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml />\n"
+ "<link rel=\"search\" type=\"application/opensearchdescription+xml\" href=http://www.example.com/search.xml";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}