use strict;
my $str = 'This should succeed:
<link rel="search" type="application/opensearchdescription+xml" href="http://example.com/tsr-opensearch/" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="http://www.example.com/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="/search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="./search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=".search.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href=\'http://www.example.com/search.xml\' title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml title="" />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/>
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/dsfdsf/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" hre href=http://href.example.com/search.xml/ />
<link rel="search" type="application/opensearchdescription+xml" ref="adfsf" href=http://href.example.com/search.xml/ />
Should fail:
<link rel="stylesheet" type="text/css" href="theme.css">
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href= http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml>
link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml />
<link rel="search" type="application/opensearchdescription+xml" href=http://www.example.com/search.xml';
my $regex = qr/<link(?=[^<>]*?opensearch)(?:[^h]+|h(?!ref))*+href=["']?\K([^<>'"\s]+(?:\/(?!>)|\b))(?=[^<>]*>)/imxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}