using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?P<first>(\d{4}|\d \d{3}))\s*x\s*(?P<second>(\d{4}|\d \d{3}))\b";
string input = @"1920 x 1080";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}