// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?P<first>(\d{4}|\d \d{3}))\s*x\s*(?P<second>(\d{4}|\d \d{3}))\b").unwrap();
let string = "1920 x 1080";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}