$re = '/\b(?P<first>(\d{4}|\d \d{3}))\s*x\s*(?P<second>(\d{4}|\d \d{3}))\b/m';
$str = '1920 x 1080';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);