const regex = new RegExp('\\b(?P<first>(\\d{4}|\\d \\d{3}))\\s*x\\s*(?P<second>(\\d{4}|\\d \\d{3}))\\b', 'gm')
const str = `1920 x 1080`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}