import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bcat(?!12\\b)\\d+";
final String string = "cat3 YES\n"
+ "cat12 NO\n"
+ "cat43 YES\n"
+ "cat18 YES\n"
+ "rel97 NO\n"
+ "cat NO\n"
+ "cat36 YES\n"
+ "cat14 YES\n"
+ "cat121\n"
+ "cat123\n"
+ "cat13\n"
+ "cat10\n"
+ "cat11\n"
+ "cat13\n"
+ "cat100\n"
+ "cat10099\n"
+ "cat130\n"
+ "cat120";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}