import re
regex = re.compile(r"\bcat(?!12\b)\d+", flags=re.MULTILINE)
test_str = ("cat3 YES\n"
"cat12 NO\n"
"cat43 YES\n"
"cat18 YES\n"
"rel97 NO\n"
"cat NO\n"
"cat36 YES\n"
"cat14 YES\n"
"cat121\n"
"cat123\n"
"cat13\n"
"cat10\n"
"cat11\n"
"cat13\n"
"cat100\n"
"cat10099\n"
"cat130\n"
"cat120")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")