const regex = /\bcat(?!12\b)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcat(?!12\\b)\\d+', 'gm')
const str = `cat3 YES
cat12 NO
cat43 YES
cat18 YES
rel97 NO
cat NO
cat36 YES
cat14 YES
cat121
cat123
cat13
cat10
cat11
cat13
cat100
cat10099
cat130
cat120`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}