using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\)[\d]{6}[^\\]*";
string input = @"str1 = <C:\User\Test\xyz\022014-101\more\stuff\022014\1>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}