re = /(?<=\\)[\d]{6}[^\\]*/
str = 'str1 = <C:\\User\\Test\\xyz\\022014-101\\more\\stuff\\022014\\1>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end