const regex = new RegExp('(?<=\\\\)[\\d]{6}[^\\\\]*', '')
const str = `str1 = <C:\\User\\Test\\xyz\\022014-101\\more\\stuff\\022014\\1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}