const regex = /^(?:[A-Za-z]{1,4}|[A-Za-z]{4}\d+)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Za-z]{1,4}|[A-Za-z]{4}\\d+)$', 'mg')
const str = `crow1111111111
crowe111111111
cro
crow
c1111111
111111crow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}