re = /^(?:[A-Za-z]{1,4}|[A-Za-z]{4}\d+)$/m
str = 'crow1111111111
crowe111111111
cro
crow
c1111111
111111crow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end