// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Za-z]{1,4}|[A-Za-z]{4}\d+)$").unwrap();
let string = "crow1111111111
crowe111111111
cro
crow
c1111111
111111crow";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}