#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^{\n]+)\s*\{\s*([^:]*?)\s*:\s*([^}]*?)\s*;?\s*}"
Local $sString = "body {background-color: red; }" & @CRLF & _
"" & @CRLF & _
"td .vanilla {background-color: blue;}" & @CRLF & _
"" & @CRLF & _
"td .vanilla {" & @CRLF & _
" color: red;" & @CRLF & _
" bg: wat;" & @CRLF & _
" how: 'bout-that';" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".name { color:green; }" & @CRLF & _
"" & @CRLF & _
".dingus-mcgood{aye:yo;}" & @CRLF & _
"" & @CRLF & _
" .wat{test:me}" & @CRLF & _
"" & @CRLF & _
"#another { key : val ; }" & @CRLF & _
"#another { key : val }" & @CRLF & _
"#another{key:val;}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")