package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^{\n]+)\s*\{\s*([^:]*?)\s*:\s*([^}]*?)\s*;?\s*}`)
var str = `body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: wat;
how: 'bout-that';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}