$re = '/([^{\n]+)\s*\{\s*([^:]*?)\s*:\s*([^}]*?)\s*;?\s*}/';
$str = 'body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: wat;
how: \'bout-that\';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);