use strict;
my $str = 'body {background-color: red; }
td .vanilla {background-color: blue;}
td .vanilla {
color: red;
bg: wat;
how: \'bout-that\';
}
.name { color:green; }
.dingus-mcgood{aye:yo;}
.wat{test:me}
#another { key : val ; }
#another { key : val }
#another{key:val;}';
my $regex = qr/([^{\n]+)\s*\{\s*([^:]*?)\s*:\s*([^}]*?)\s*;?\s*}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}