# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([0-1][0-9])|([2][0-3])):([0-5][0-9])(:([0-5][0-9]))?([.]\d{3})?$//gm;t' <<< "23:59
23:59:30
23:59:34.123
23:59:12
23:60
23:59.
23:59.60"